Continued access issues for some integrations and interfaces due to missing intermediate certificates

Incident Report for Fenwick

Resolved

This incident has been resolved.
Posted Apr 15, 2026 - 11:28 AEST

Monitoring

A fix has been deployed and should start to resolve any remaining connection issues. Please try establish a connection again.

- You can now remove any intermediate certificates from keystores if added temporarily (RapidSSL TLS RSA CA G1 / 0B:25:94:22:CE:D9:81:2A:15:A0:4E:99:52:8A:0E:FA)

The root certificate (DigiCert Global Root G2 / 03:3A:F1:E6:A7:11:A9:A0:BB:28:64:B1:1D:09:FA:E5) is still required though should form part of your OS's routine updates.
Posted Apr 15, 2026 - 10:44 AEST

Identified

We've identified that the intermediate certificates aren't being issued with the latest renewal of the SSL cert for our Fenwick Cloud customers.

A manual copy of the certificates can be obtained from https://knowledge.digicert.com/general-information/digicert-trusted-root-authority-certificates with the following serials:

- DigiCert Global Root G2 (Serial 03:3A:F1:E6:A7:11:A9:A0:BB:28:64:B1:1D:09:FA:E5)
- RapidSSL TLS RSA CA G1 (Serial 0B:25:94:22:CE:D9:81:2A:15:A0:4E:99:52:8A:0E:FA)

We'll provide an update here as soon as it's resolved.
Posted Apr 15, 2026 - 10:00 AEST
This incident affected: Fenwick Cloud (Hosted Platform).