Services are restoring and connections should start coming back up.
Posted Jan 22, 2026 - 11:53 AEDT
Identified
We've identified an issue where a select set of customers are unable to access Dynamics NAV or Business Central at this time. We'll keep this issue updated as remediations progress.
Posted Jan 22, 2026 - 11:35 AEDT
This incident affected: Fenwick Cloud (Hosted Platform).