Heavy load on Mail server causing delays in sending mail
Incident Report for Fenwick
Resolved
Resolved backlog. Any failed mail will need to be resent via the system.
Posted Sep 10, 2021 - 10:54 AEST
Investigating
We are currently investigating this issue.
Posted Sep 10, 2021 - 10:21 AEST
This incident affected: Fenwick Cloud (Mail).